#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\([^)]*\)"
Local $sString = "here is some normal text (this comment should be removed) that should not be deleted" & @CRLF & _
"(comment by itself on a line)" & @CRLF & _
"(comment starting) but then some text." & @CRLF & _
"random start of string ( here is a comment" & @CRLF & _
"spanning two lines ) even with some text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")