use strict;
my $str = 'here is some normal text (this comment should be removed) that should not be deleted
(comment by itself on a line)
(comment starting) but then some text.
random start of string ( here is a comment
spanning two lines ) even with some text';
my $regex = qr/\([^)]*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}