re = /\([^)]*\)/m
str = 'here is some normal text (this comment should be removed) that should not be deleted
(comment by itself on a line)
(comment starting) but then some text.
random start of string ( here is a comment
spanning two lines ) even with some text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end