#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^((\D*)|(.{0,4})|(.{6,})|(00000)|(\D+\d+.*)|(\d+\D+.*))$"
Local $sString = "00000" & @CRLF & _
"zahir" & @CRLF & _
"31z44" & @CRLF & _
"z38vr" & @CRLF & _
"2331" & @CRLF & _
"444444" & @CRLF & _
"zahir 22" & @CRLF & _
"13325"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")