re = /(?<=\/dp\/).*?(?=\/)/
str = 'http://www.amazon.fr/Les-cahiers-d%C3%A9criture-n%C2%BA1-Apprentissage/dp/221895608X/ref=zg_bs_3967461_1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end