#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^(?:dames|heren|schoenen us)\s+([a-z]*\s*)(?:([a-z]+)[\s/]*$|\D*(\d+)(?:[\s/]*$|(\s+\/\s+)\D*(\d+).*$))"
Local $sString = "Schoenen US 30 / " & @CRLF & _
"Dames US 30 / " & @CRLF & _
"Dames US w30 / " & @CRLF & _
"Heren US w30 / L34" & @CRLF & _
"Dames US L /"
Local $sSubst = "$1$2$3$4$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)