$re = '/-([^-\s]+)/';
$str = 'Some Text
Another Text
-something/3443/kk-somethingelse/111/333/zz
-text/ff/33/33/zz
Text Text
Text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);