$re = '/(?<!jeffery)@.+/m';
$str = 'jeffery@envato.com
fred@envato.com
jeffer@gmail.com
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;