re = /^(?:\w+|\w+\.\w+)+$/mi
str = 'com
com.package
com.package.test
.
com.invalid.
com.invalid..ff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end