const regex = /(\n|\\n)(?!$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\n|\\\\n)(?!$)', 'g')
const str = `sdgfsdjkhfsdjif
sdklfjsdklfjsdkl
sdkljhsdklfjsdklsdfj
lsjdfllfksdfsdf\\nsjdfklsdfjksdhfsdk
sdjkfsdjkfhsdlfs
dfsdjfjsdf
sdfidklgjsd
sdfkjfsd
fdsjfkjsd\\nsdfhjsdhfsdj\\nsdjhfsdklhfksd\\nnsdkfhsdkljfsdkl\\\\njsdfljsdklfjsdlkfjsdlkjfsdkljflksdkjfskl`;
const subst = `<br />`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);