$re = '/((?<=\()[^)]+)/';
$str = '((1 or 2) and (3 and 4))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);