package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^0-9\s.][a-z]+.[a-z]+$`)
var str = `ddfdsfsdfsfsf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}