$re = '/^[^0-9\s.][a-z]+.[a-z]+$/';
$str = 'ddfdsfsdfsfsf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);