package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([^\]]*)\]|(\S+)`)
var str = `CODE FIRSTTYPE: [DATA OF FIRST TYPE] SECONDTYPE: [DATA OF SECOND TYPE]`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}