use strict;
my $str = '$form->AddFields({
id => 2048
type => \'hidden\',
name => \'xyz\',
value => 0,
});
$form->AddFields({
type => \'hidden\',
name => \'xyz\',
value => 0,
});
$form->AddFields({
type => \'hidden\',
name => \'xyz\',
id => 1024,
value => 0,
});
$form->AddFields({
type => \'hidden\',
name => \'abc\',
value => 10,
});';
my $regex = qr/\$form->AddFields\({(?![^}]+id =>)[^}]+}\);/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}