import Foundation
let pattern = #"\$form->AddFields\({(?![^}]+id =>)[^}]+}\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$form->AddFields({
id => 2048
type => 'hidden',
name => 'xyz',
value => 0,
});
$form->AddFields({
type => 'hidden',
name => 'xyz',
value => 0,
});
$form->AddFields({
type => 'hidden',
name => 'xyz',
id => 1024,
value => 0,
});
$form->AddFields({
type => 'hidden',
name => 'abc',
value => 10,
});
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)