#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?Uum)<BR><B>(.*)<\/B>|= ([\w\s]+?|)$|= ([\w\s]+?|)"
Local $sString = "Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> = sssssss" & @CRLF & _
"" & @CRLF & _
"Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Kultura</B> = <BR><B>Kul</B> = zzzzzzzzz dstset" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")