use strict;
my $str = 'Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> = sssssss
Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Kultura</B> = <BR><B>Kul</B> = zzzzzzzzz dstset
';
my $regex = qr/<BR><B>(.*)<\/B>|= ([\w\s]+?|)$|= ([\w\s]+?|)/ump;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}