re = /<BR><B>(.*)<\/B>|= ([\w\s]+?|)$|= ([\w\s]+?|)/m
str = 'Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> = sssssss
Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Kultura</B> = <BR><B>Kul</B> = zzzzzzzzz dstset
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end