$re = '/(?:(?:https?)+\:\/\/+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif|bmp|webp|pna|tiff|svg))/sim';
$str = 'https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg
src="../c624121/v624121992/3cf22/YRIx_w-QySg.png"
https://pp.vk.me/c624121/v624121992/3cf22/jpg/YRIx_w-QySg.jpg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.webp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.tiff
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.pna
https://pp.vk.me/c624121/v624121992/3cf22/svg/YRIx_w-QySg.svg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);