package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*?(abc)|.*?(a.c)|.*?(def)|.*?(%#@)|.*?(1z;))`)
var str = `1z;%#@defarcabcaqcdef%#@1z;
1z;%#@defarcabaqcdef%#@1z;
1z;%#@defacabacdef%#@1z;
1z;%#@deacabacdf%#@1z;
foo;%@deaabade#@1z;barbbbaarr3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}