#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)[+-]?(?:\d+(?:\.\d+)?|\([ \t]*(?R)[ \t]*\)) (?:[ \t]*[*+/-][ \t]* [+-]?(?:\d+(?:\.\d+)?|\([ \t]*(?R)[ \t]*\)))*"
Local $sString = "( (1 + 0.2) * 2) * (-(1 + (2 - 3) ) - -16), 6 + 3 , -6 * (1+2) , 6 * -(1+2), 12.23 , (23.34) "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")