import Foundation
let pattern = #"[+-]?(?:\d+(?:\.\d+)?|\([ \t]*(?R)[ \t]*\)) (?:[ \t]*[*+/-][ \t]* [+-]?(?:\d+(?:\.\d+)?|\([ \t]*(?R)[ \t]*\)))*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"( (1 + 0.2) * 2) * (-(1 + (2 - 3) ) - -16), 6 + 3 , -6 * (1+2) , 6 * -(1+2), 12.23 , (23.34) "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)