use strict;
my $str = 'testfoobartest';
my $regex = qr/test(.+)test/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";