package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<[ ]*(\/)?(.*)?script([ ]+.*|[^\w]*)>`)
var str = `<script>gdfgdfgfdg
</script>
<script>gdfgdfg
< script>gdfg
<SCRiPt >gfdgfdgdfg
<script> alert(); </script>dgfgdg
< scRipT type="text/javascript">;</scriPt >
<script>
< ScrIpT nn >
<SCRiPT >
< script type="js"> etc.
hi
<img>
<img script>
<scripting>
<s cr i pt>
<xxscriptxx>
< scRipT type="text/javascript">;</ scriPt >`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}