use strict;
my $str = '<script>gdfgdfgfdg
</script>
<script>gdfgdfg
< script>gdfg
<SCRiPt >gfdgfdgdfg
<script> alert(); </script>dgfgdg
< scRipT type="text/javascript">;</scriPt >
<script>
< ScrIpT nn >
<SCRiPT >
< script type="js"> etc.
hi
<img>
<img script>
<scripting>
<s cr i pt>
<xxscriptxx>
< scRipT type="text/javascript">;</ scriPt >';
my $regex = qr/<[ ]*(\/)?(.*)?script([ ]+.*|[^\w]*)>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}