# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-\d+x\d+(\.[^.\s]+)$/$1/gm;t' <<< "http://az648995.vo.msecnd.net/win/2015/11/Halo-1024x551.jpg
http://az648995.vo.msecnd.net/win/2015/11/slot-Drake-08-2000x1000-1024x512.jpg"