package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^5((0[0-9]|[3-5]\d)|(92)) \d{3} \d{4}$`)
var str = `Turkcell
530 123 4567
531 123 4567
532 123 4567
533 123 4567
534 123 4567
535 123 4567
536 123 4567
537 123 4567
538 123 4567
539 123 4567
Türk Telekom Mobil
500 123 4567
501 123 4567
502 123 4567
503 123 4567
504 123 4567
505 123 4567
506 123 4567
507 123 4567
508 123 4567
509 123 4567
550 123 4567
551 123 4567
552 123 4567
553 123 4567
554 123 4567
555 123 4567
556 123 4567
557 123 4567
558 123 4567
559 123 4567
Vodafone
540 123 4567
541 123 4567
542 123 4567
543 123 4567
544 123 4567
545 123 4567
546 123 4567
547 123 4567
548 123 4567
549 123 4567
Globalstar
592 211 9999
592 212 0888
Teknomobil
592 113 0900
592 113 1900
592 113 2900
592 113 3900
592 113 4900
592 113 5900
592 113 6900
592 110 0900
592 110 1900
592 110 2900
592 110 3900
592 110 4900
592 110 5900
592 110 6900
TB Haberleşme
592 616 0900
592 616 1900
592 616 2900
592 616 3900
592 616 4900
Medium Telekom
592 216 9999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}