# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(?:\[|\()(?:M|F|T|MF|FM|\?)(?:\d+)?(?:M|F|T|MF|FM|\?)?(?:\d+)?(?:\]|\))"
test_str = ("[F]\n"
"(F)\n"
"[M]\n"
"(M)\n"
"[T]\n"
"(T)\n"
"[FM]\n"
"[MF]\n"
"(FM)\n"
"(MF)\n"
"[F44]\n"
"(f45)\n"
"[F44M50]\n"
"[M21F31]\n"
"(F44M50)\n"
"(M21F31)")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.