#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"(?<VoNo>[^"]*)";"(?<VoDt>[^"]*)";"(?<ValDt>[^"]*)";"(?<VoTp>[^"]*)";"(?<Txt>[^"]*)";"(?<DbAcNo>[^"]*)";"(?<DbTrnCl>[^"]*)";"(?<DbTxCd>[^"]*)";"(?<CrAcNo>[^"]*)";"(?<CrTrnCl>[^"]*)";"(?<CrTxCd>[^"]*)";"(?<Am>[^"]*)";"(?<InvoNo>[^"]*)";"(?<DueDt>[^"]*)";"(?<VatAm>[^"]*)";"(?<R1>[^"]*)";"(?<R2>[^"]*)";"(?<R7>[^"]*)";"(?<CID>[^"]*)";"(?<Txt2>[^"]*)";"(?<AGRef>[^"]*)";;"
Local $sString = "@Actor (=CustNo,SupNo,Nm,Ad1,Ad2,Ad3,PNo,PArea,Phone,Fax,MailAd,BsNo,BGiro,Ctry,Lang,Cur,CPmtTrm,SPmtTrm)" & @CRLF & _
""10458";"0";"Vesterlandet GÂrd / D. Hansen";"Vesterlandet 226";"";"";"8407";"Sortland";"";"";"vesterlandetgaard@gmail.com";"926967878";"";"47";"47";"";"15";"15"" & @CRLF & _
"" & @CRLF & _
"@IMPORT_METHOD(3)" & @CRLF & _
"" & @CRLF & _
"@WaBnd (ValDt, SrcTp, Descr)" & @CRLF & _
""20240326" "12" "Quick3 Import"" & @CRLF & _
"@WaVo (VoNo,VoDt,ValDt,VoTp,Txt,DbAcNo,DbTrnCl,DbTxCd,CrAcNo,CrTrnCl,CrTxCd,Am,InvoNo,DueDt,VatAm,R1,R2,R7,CID,Txt2,AGRef)" & @CRLF & _
""100489";"20240326";"20240326";"11";"Utg.faktura";"10458";"0";"0";"0";"0";"0";"33818.00";"100489";"20240405";"";"";"";"";"001045801004890";"";"";;" & @CRLF & _
""100489";"20240326";"20240326";"11";"Utg.faktura";"0";"0";"0";"7740";"0";"0";"0.50";"";"";"";"";"";"";"";"";"";;" & @CRLF & _
""100489";"20240326";"20240326";"11";"Utg.faktura";"0";"0";"0";"3000";"0";"3";"30937.50";"";"";"";"1";"";"";"";"";"";;" & @CRLF & _
""100489";"20240326";"20240326";"11";"Utg.faktura";"0";"0";"0";"3001";"0";"3";"2880.00";"";"";"";"1";"";"";"";"";"";;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")