import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?![^<]*?>)\\b[\\w\\h]{7,})";
final String string = "<html>\n"
+ " <tabel tags=\"gohere'>\n"
+ " <tr>\n"
+ " <td>detects strings</td>\n"
+ " <td>\n"
+ " of a\n"
+ " length\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>\n"
+ " and <b> ignores HTML </b>\n"
+ " <br />\n"
+ " formating\n"
+ " </td>\n"
+ " <td> this checks for string atleast 7 char in length <td>\n"
+ " </tr>\n"
+ " </table>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}