const regex = /[a-z]+/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z]+', 'i')
const str = `Welcome to Regex101.com. To get started, simply input a regex and a test string in the boxes above. Alternatively, click here to try out an example! You can retake the initial tour guide by clicking here.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}