package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\s*(?:\"([^\"]*)\"|([^,]+))\s*,?)+?`)
var str = `dgsfdgsdg dfgdsfg "30",2014-08-08,"100","MT","8","3624","#","#",1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}