#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^ # Assert begin of line" & @CRLF & _
" (?= # First zero-with lookahead" & @CRLF & _
" ( # Capturing group 1" & @CRLF & _
" a # Match a" & @CRLF & _
" (?1)? # Recurse group 1 optionally" & @CRLF & _
" b # Match b" & @CRLF & _
" ) # End of group 1" & @CRLF & _
" c+ # Match c one or more times" & @CRLF & _
" ) # End of the first lookahead" & @CRLF & _
"" & @CRLF & _
" (?= # Second zero-with lookahead" & @CRLF & _
" a+ # Match a one or more times" & @CRLF & _
" ( # Capturing group 2" & @CRLF & _
" b # Match b" & @CRLF & _
" (?2)? # Recurse group 2 optionally" & @CRLF & _
" c # Match c" & @CRLF & _
" ) # End of group 2" & @CRLF & _
" ) # End of the second lookahead" & @CRLF & _
"a+b+c+ # Match each of a,b and c one or more times" & @CRLF & _
"$ # Assert end of line"
Local $sString = "abc" & @CRLF & _
"aabbcc" & @CRLF & _
"aaabbbccc" & @CRLF & _
"" & @CRLF & _
"abbc" & @CRLF & _
"aabbc" & @CRLF & _
"aabbbccc" & @CRLF & _
"" & @CRLF & _
"ab" & @CRLF & _
"aabb" & @CRLF & _
"aaabbb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")