#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<!--((?!batcache)(?!\[endif\])[\s\S])*?-->"
Local $sString = "<!--[if IE 6]>" & @CRLF & _
" Special instructions for IE 6 here" & @CRLF & _
"<![endif]-->" & @CRLF & _
"" & @CRLF & _
"<!--" & @CRLF & _
"generated 37 seconds ago" & @CRLF & _
"generated in 0.978 seconds" & @CRLF & _
"served from batcache in 0.004 seconds" & @CRLF & _
"expires in 263 seconds" & @CRLF & _
"-->" & @CRLF & _
"" & @CRLF & _
"<!--asdasd asldasldkaslòdk" & @CRLF & _
" batcahe" & @CRLF & _
"asd" & @CRLF & _
"as-->" & @CRLF & _
"" & @CRLF & _
"<!--asdasd asldasldkaslòdk" & @CRLF & _
" batcaRO" & @CRLF & _
"asd" & @CRLF & _
"as-->" & @CRLF & _
"" & @CRLF & _
"<!--asdasd asldasldkaslòdk" & @CRLF & _
" batcache" & @CRLF & _
"asd" & @CRLF & _
"as-->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")