import Foundation
let pattern = #"<!--((?!batcache)(?!\[endif\])[\s\S])*?-->"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<!--[if IE 6]>
Special instructions for IE 6 here
<![endif]-->
<!--
generated 37 seconds ago
generated in 0.978 seconds
served from batcache in 0.004 seconds
expires in 263 seconds
-->
<!--asdasd asldasldkaslòdk
batcahe
asd
as-->
<!--asdasd asldasldkaslòdk
batcaRO
asd
as-->
<!--asdasd asldasldkaslòdk
batcache
asd
as-->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)