using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w*";
string input = @"MyNickName CSGOFLIME.NET
MyNickName HTTP://CSGOFLIME.NET
MyNickName http://www.CSGOFLIME.NET
MyNickName www.CSGOFLIME.NET";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}