$re = '/^\w*/m';
$str = 'MyNickName CSGOFLIME.NET
MyNickName HTTP://CSGOFLIME.NET
MyNickName http://www.CSGOFLIME.NET
MyNickName www.CSGOFLIME.NET';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);