using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9]{4}((0[1-9])|(1[0-2]))((0[1-9])|([1-2][0-9])|(3[0-1]))((([0-1][0-9])|(2[0-3]))[0-5][0-9][0-5][0-9](\.[0-9]{3}((\[[\+\-]?(0[0-9]|1[0-4])(:(00|30|45))?\])?)?)?)?)$";
string input = @"20150805110626.951[-11:00]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}