$re = '/\b(
\w*
(?:
[fc]+(?:\W*[uoc]*)*k+|
di+(?:\W*c*)*k+|
c+(?:\W*[un]*)*t+|
s+(?:\W*[hia]*)*t+|
b+(?:\W*(?:[ich]|ea)*)*t+(?:\W*(?:[ich]|ea)*)*h+|
a[$s]|
arse
)
\w*
)\b/x';
$str = 'fuck
f.cuk
fck
theres this fucking fuck you f.uck fkuck fuckfinhg
fuck fck
fock
fucccckkkkkkkkkkkkkkingggggg
sjns skndnsiofns
f
u
k
u
fffff.uuuuuu.kkkkkk
fucked shit idiot asshole
shit fuck
shat shitty
Other words...
dick dicking dickhead but not dock or duck
cock but not penis or phallus
cunt but not contain or cunilingus
bitch bitching but not batch or botching
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);