// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)\b(
\w*
(?:
[fc]+(?:\W*[uoc]*)*k+|
di+(?:\W*c*)*k+|
c+(?:\W*[un]*)*t+|
s+(?:\W*[hia]*)*t+|
b+(?:\W*(?:[ich]|ea)*)*t+(?:\W*(?:[ich]|ea)*)*h+|
a[$s]|
arse
)
\w*
)\b").unwrap();
let string = "fuck
f.cuk
fck
theres this fucking fuck you f.uck fkuck fuckfinhg
fuck fck
fock
fucccckkkkkkkkkkkkkkingggggg
sjns skndnsiofns
f
u
k
u
fffff.uuuuuu.kkkkkk
fucked shit idiot asshole
shit fuck
shat shitty
Other words...
dick dicking dickhead but not dock or duck
cock but not penis or phallus
cunt but not contain or cunilingus
bitch bitching but not batch or botching
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}