# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\A|\s)#(\w+)"
test_str = "This is #hashtag finder that looks for all the #tags in a tweet object!"
subst = "\\1#<a href=\"http://search.twitter.com/search?q=%23\\2\">\\2</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.