#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\/\/ .*$"
Local $sString = "fdsafda" & @CRLF & _
"gsdf" & @CRLF & _
"fdsasdf // " & @CRLF & _
"sdfgsdf" & @CRLF & _
"// gfdsgfdsg" & @CRLF & _
"gsdfgsdf" & @CRLF & _
"sagsdfg fdsgsdfgsdf gfdsgsdgsdfg fdsz " & @CRLF & _
"fdsafsda // fdsafsafsda" & @CRLF & _
"" & @CRLF & _
"Te się nie łapią:" & @CRLF & _
"//fdfdfdf fd f" & @CRLF & _
"fdsfdsa //fsdafdsa" & @CRLF & _
"fdsafdsa fdsafsda//fdsafdas"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")