// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*\/\/ .*$").unwrap();
let string = "fdsafda
gsdf
fdsasdf //
sdfgsdf
// gfdsgfdsg
gsdfgsdf
sagsdfg fdsgsdfgsdf gfdsgsdgsdfg fdsz
fdsafsda // fdsafsafsda
Te się nie łapią:
//fdfdfdf fd f
fdsfdsa //fsdafdsa
fdsafdsa fdsafsda//fdsafdas";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}