import Foundation
let pattern = #"^.*\/\/ .*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
fdsafda
gsdf
fdsasdf //
sdfgsdf
// gfdsgfdsg
gsdfgsdf
sagsdfg fdsgsdfgsdf gfdsgsdgsdfg fdsz
fdsafsda // fdsafsafsda
Te się nie łapią:
//fdfdfdf fd f
fdsfdsa //fsdafdsa
fdsafdsa fdsafsda//fdsafdas
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)