const regex = /(.*),([^,]+)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*),([^,]+)$', 'g')
const str = `INSERT INTO Customers (CustomerName, ContactName, Address, ) VALUES (\\"Cardinal\\", \\"Tom B. Erichsen\\", \\"Skagen 21\\",)`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);