re = /(?<=[T|t]he\s)(day|boy)/m
str = 'The day was bright, and the boy was happy.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end