package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w`)
var str = `Value of $ is increasing in the market.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}