using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?P<error_date>^[\w\/\.]+)\s+(?P<error_time>[\w\/\.\:]+)\s+\*(?P<error_level>\w+)\*\s+\[((?P<error_ip>[\d\.]+)\s+\[(?P<error_thread_id>.+)\]\s+(?P<error_request_method>\w+)\s+(?P<error_urlpath>.+)\s+(?P<error_req_protocol>.+)|(?P<error_thread>.+?))\]\s+(?P<error_message>.+[\n]?.+)";
        string input = @"
14.05.2021 11:52:20.598 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [31211, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED
14.05.2021 11:52:22.964 *WARN* [10.153.117.93 [1620993142877] GET /content/ewp-marketing-websites/legal/gl/en/c/prolaw-workspace.html HTTP/1.1] com.tr.emcm.slingmodels.EyeBrowDateModel Error while formatting date: 
java.text.ParseException: Unparseable date: ""
	at java.text.DateFormat.parse(DateFormat.java:366)
	at com.tr.emcm.slingmodels.EyeBrowDateModel.setDate(EyeBrowDateModel.java:92)
	at com.tr.emcm.slingmodels.EyeBrowDateModel.lambda$init$2(EyeBrowDateModel.java:72)
14.05.2021 11:52:22.972 *ERROR* [10.43.32.58 [1620993142925] GET /content/volvo/volvo-financial-services/markets/netherlands/nl-nl/home.html HTTP/1.1] com.volvo.platform.components.controllers.VolvoGroupStandardHeaderComponent RepositoryException Error occured while processing fetchExcelValues/content/volvo/volvo-financial-services/markets/netherlands/nl-nl/jcr:content/header
javax.jcr.AccessDeniedException: OakAccess0000: Access denied
	at org.apache.jackrabbit.oak.api.CommitFailedException.asRepositoryException(CommitFailedException.java:232)
	at org.apache.jackrabbit.oak.api.CommitFailedException.asRepositoryException(CommitFailedException.java:213)
	at org.apache.jackrabbit.oak.jcr.delegate.SessionDelegate.newRepositoryException(SessionDelegate.java:669)
14.05.2021 11:52:22.980 *WARN* [10.105.105.19 [1620993142700] GET /content/onehub_nfz/de/de/angebote-und-finanzprodukte/gross-und-sonderkunden/kommunen-und-behoerden.dir.dir.dir.dir.dir.dir.dir.dir.dir.dir.dir.dir.html/__layer/layers/fahrzeugkauf/ansprechpartner-blaulichtfahrzeuge HTTP/1.1] org.apache.sling.caconfig.resource.impl.def.DefaultConfigurationResourceResolvingStrategy Ignoring reference to /conf/vwa-ngw18/settings from /conf/vwa-ngw18/settings - Probably misconfigured as it ends with '/settings'";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}