const regex = /((?:\d\.)?(?:\d{1,3}\.)?\d{1,3},\d{1,2})|(\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\d\\.)?(?:\\d{1,3}\\.)?\\d{1,3},\\d{1,2})|(\\d)', 'g')
const str = `1.000,20
5.611.000,20
541.000,00
10,20
0
0,20
9.999.999,99`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}